M1 Support for Red Giant Plugins

Kristina K.
Kristina K.

All Red Giant Complete and Maxon One versions of Red Giant plugins are compatible with Mac M1 GPUs.

Perpetual and older versions of plugins are not compatible with Mac M1 GPUs.

 

For more details about environmental requirements, please visit our requirements page.

 

Was this article helpful?

/

Comments

3 comments

  • Comment author
    Kristina K.

    Hi folks,

    We aren't set up to monitor and comment on these knowledge base articles, so if you have questions or see an issue, please submit a support ticket. That all said, among today's release was a new Trapcode, which includes M1 support for all tools.

    3
  • Comment author
    Kristina K.

    Today's new release for Universe, 5.1, introduces M1 support.

    0
  • Comment author
    Kristina K.

    With the release of VFX 2.0 and Magic Bullet 15.0 today, we are excited to announce partial compatibility with M1 machines. Keep your eyes on the article for additional compatibility with upcoming releases.

    0

Article is closed for comments.