Cinema 4Dのプロジェクトは、ネットワークドライブに保存したり、ネットワークドライブから直接開いたりできます。その際は、コンピューターとサーバーが安定して接続されていることに加え、プロジェクトファイル、およびテクスチャ、キャッシュ、XRefなどの関連ファイルにアクセスできることを確認してください。
保存中にネットワーク接続が切断されると、プロジェクトが正常に保存されなかったり、ファイルが破損したりする可能性があります。そのため、特にプロジェクトのデータ量が大きい場合やネットワーク接続が不安定な場合は、可能な限りローカルにコピーして作業することをお勧めします。
作業が完了したら、更新したプロジェクトをネットワークドライブへコピーしてください。
※保存時の競合を避ける
同じCinema 4Dプロジェクトを複数のユーザーが同時に編集、保存しないようにしてください。
また、プロジェクトフォルダーをコピーまたは同期する前に、保存処理が完了していることを確認してください。
推奨ワークフロー
-
ローカルに作業用コピーを作成します:
プロジェクトフォルダー全体をローカルドライブへコピーします。アセットが別の場所に保存されている場合は、後述のプロジェクトアセットを収集する手順に従ってください。ローカルコピーが問題なく使用できることを確認するまでは、ネットワークドライブ上の元のプロジェクトを削除したり、上書きしたりしないでください。
-
ローカルコピーを確認します:
ローカルコピーを開き、ウィンドウ > プロジェクトアセットインスペクタを選択します。絶対パス列を確認し、ネットワーク上のファイルを参照したままになっていないか確認してください。緑色のチェックマークは、Cinema 4Dがそのアセットを検出できたことを示すもので、ローカルに保存されていることを示すものではありません。作業に必要なファイルをローカルにコピーし、見つからないアセットを再リンクしてから、テストレンダリングを行ってください。
-
ローカルで編集、保存します:
作業中は、プロジェクトをローカルのプロジェクトフォルダーに保存してください。キャッシュとレンダリング出力の保存先にも、ローカルフォルダーを指定します。
-
作業が完了したプロジェクトをネットワークドライブへ戻します:
作業中に追加したアセットも忘れずにコピーしてください。すべての保存処理とキャッシュの書き込みが完了してからプロジェクトを閉じ、転送中に内容が変更されないようにします。その後、プロジェクトフォルダー全体をネットワークドライブへコピーしてください。転送が完了したらコピー先のプロジェクトを確認し、問題がないことを確認してから旧バージョンを置き換えます。Cinema 4D自体を終了する必要はありません。
プロジェクトアセットを収集する
プロジェクトを開き、**ファイル > アセットと一緒にプロジェクト保存...**を選択します。Cinema 4Dが収集可能な外部アセットをまとめた、新しいプロジェクトのコピーが作成されます。保存先にはローカルドライブを指定してください。相対パスに対応しているアセットについては、プロジェクトフォルダーを基準とするパスにリンクが更新されるため、プロジェクトと関連ファイルをまとめて移動しやすくなります。
Cinema 4Dでアセットが見つからないというメッセージが表示された場合は、処理を続ける前に該当するファイルを指定してください。いいえを選択すると、そのファイルを除外して処理を続行します。キャンセルを選択すると処理は中止されますが、それまでに新しいフォルダーへコピーされたファイルは残ります。いずれの場合も、作成されたプロジェクトフォルダーに必要なファイルがすべて揃っていない可能性があります。
プロジェクトでアセットブラウザのデータベースに保存されているアセットを使用しており、後からそのデータベースにアクセスできない環境で作業する必要がある場合は、アセットを収集する前に次の設定を確認してください。
- Cinema 4Dの設定を開きます。
- **インポート/エクスポート > Cinema 4D エクスポート**を開き、データベースアセットと一緒にプロジェクトを保存...を選択します。
-
ファイルアセットをテクスチャフォルダーにコピーとノードアセットをシーンデータベースにコピーを有効にします。
- 「設定」を閉じ、**ファイル > アセットと一緒にプロジェクト保存...**を選択して、プロジェクトとアセットを保存します。
これらのオプションを有効にすると、ファイルアセットはプロジェクトのテクスチャフォルダーにコピーされ、ノードアセットはシーンファイル内に保存されます。
個別に対応が必要なファイルを確認する
XRefシーンが別のファイルを参照している場合や、XRefシーン内にさらに別のXRefが含まれている場合、それらのファイルは、メインプロジェクトでアセットと一緒にプロジェクト保存...を実行しても自動的には収集されません。該当するファイルは個別にコピーしてください。また、GIキャッシュなどのファイルでは絶対パスが使用される場合があるため、プロジェクトを移動した後に保存先や参照先を設定し直す必要があります。
プロジェクトアセットインスペクタには、スカルプトブラシで使用しているテクスチャなど、ツールから参照されるアセットは表示されません。作業に必要なツール用アセットについては、別途確認してください。収集したプロジェクトを元のアセット保存場所にアクセスできない環境でも使用する必要がある場合は、元の保存場所にアクセスできない状態でプロジェクトを開き、問題なく使用できるかテストすることをお勧めします。
見つからないアセットを検索して再リンクする方法
-
ウィンドウ > プロジェクトアセットインスペクタを開きます。
- すべてのアセットが一覧に表示されるよう、アセットのフィルターをすべて解除してから、
編集 > 不明なアセットを選択を選びます。 - **アセット > アセットを再リンク...**を選びます。
- 見つからないファイルが保存されているフォルダーを選択します。
- 修正したプロジェクトを保存します。
再リンクは、ファイルの参照先を Cinema 4D に指定する操作であり、ファイル自体をコピーするものではありません。再リンク後に**アセットを含むプロジェクトを保存...**を使用し、必要なファイルをプロジェクトと一緒に収集してください。ノードアセットが見つからない場合は、先にアセットブラウザで該当するデータベースへ再接続してください。
ネットワークドライブ上で直接作業する必要がある場合
ネットワークドライブ上のプロジェクトを直接開いて保存する必要がある場合は、次の点をIT担当者に確認してください。
- 安定した低遅延のネットワーク接続を使用してください。データ量の大きいプロジェクトを扱う場合は、有線接続をお勧めします。
- 必要なアセットを読み込めることに加え、プロジェクト、キャッシュ、レンダリング出力の各フォルダーにファイルを保存できることを確認してください。共有アセットライブラリへの書き込み権限が必要なのは、ライブラリ内のファイルを変更する場合のみです。
- プロジェクトを開いたりレンダリングしたりするすべてのコンピューターから、シーンに保存されているパスを使用して関連ファイルにアクセスできることを確認してください。
バックアップと自動保存
作業中は、日付や連番を付けてプロジェクトを別バージョンとして保存してください。また、使用しているすべてのアセットを含め、プロジェクトフォルダー全体を定期的にバックアップすることをお勧めします。
自動保存ファイルはローカルドライブに保存する
設定 > ファイル > 自動保存を開いて自動保存を有効にし、保存先フォルダーをカスタムに設定して、ローカルフォルダーを指定します。プロジェクトを選択した場合、自動保存ファイルはシーンファイルと同じ場所にあるバックアップフォルダーへ保存されます。プロジェクトがネットワークドライブ上にある場合、自動保存ファイルもネットワークドライブ上に保存されます。
問題が解決しない場合
まず、上記の手順に従ってプロジェクトをローカルへコピーし、同じ問題が発生するか確認してください。ネットワークドライブ上でのみ問題が発生する場合は、ネットワーク接続、サーバー、アクセス権限、ファイルパスについてIT担当者へ確認を依頼してください。
ローカルへコピーしても同じ問題が発生する場合は、元のファイルを削除せずに保管してください。破損したプロジェクトをローカルドライブへコピーしても、ファイル自体は修復されません。さらにサポートが必要な場合は、正確なエラーメッセージ、使用しているCinema 4Dのバージョン、ローカル環境でのテスト結果を添えて、サポートチケットを送信してください。
コメント
0件のコメント
記事コメントは受け付けていません。