如需查看 Cinema 4D 2026.7 及其他 Maxon 产品的完整系统要求,请访问我们的系统要求页面。
如果您在 ARM 架构设备上下载,请务必先将显卡驱动更新至最新版本。Qualcomm 最新驱动可在其官方网站获取。
此版本包含 Redshift 2070.0
新功能
散布生成器与散布标签
这套程序化系统可在表面上散布大量实例,同时让您灵活控制最终效果。分布模式包括表面网格、面积加权、UV 网格和样条投射,并支持密度贴图、松弛和重叠消除。因此,散布实例可以真正做到互不重叠,而不仅仅是视觉上看起来没有重叠。该系统与 MoGraph 深度集成,支持在散布后进一步添加变化和动画。
- 变化可为每个实例随机设置位置、旋转、缩放和颜色,并支持沿表面法线对齐及朝向指定目标。顶点贴图可用于局部控制。
- 过滤器可根据高度、坡度、曲率和到网格边界的距离限制实例的放置区域。每种过滤器均提供 Breakup 控件,使过渡更加自然。
- 集群使用 Voronoi 噪波函数,将实例聚集到密集区域。您可以为各个对象指定集群 ID,使不同资产出现在不同区域。
- 邻近可使用样条或其他散布生成器遮罩实例,或根据距离控制实例的缩放。典型用途包括避开障碍物、降低道路附近的分布密度,以及在吸引目标周围生成实例。
- 散布标签可为每个对象设置散布概率、过滤条件、变换和集群分配。
Liquid FX
Liquid FX 可在现有液体模拟的基础上添加飞溅、泡沫和气泡,无需大幅提高模拟分辨率即可增加细节。该功能由两个新对象驱动。Liquid FX 发射器根据模拟本身的估算数据(如被卷入液体的空气和浪峰)程序化生成粒子。Liquid FX 修改器则可直接转换现有粒子。粒子会响应周围的液体,并根据相邻粒子的数量自动切换类型。飞溅粒子依惯性运动,泡沫粒子在距液体表面一定偏移的位置随周围的速度场漂移,气泡粒子则随液体漂移并在浮力作用下上升。
节点场、节点效果器与采样场节点
节点场对象可通过节点图构建自定义场,其效率高于 Python 场,功能也比公式场更强大。节点效果器可通过相同方式处理 MoData,并可按需自定义强度和选择权重的处理方式。新的采样场节点可在任意场景节点设置中对场列表进行采样,并在循环内高效地批量处理采样。这三项功能均提供数组模式,适用于高级设置。节点场和节点效果器均兼容 MCP,因此您可以借助 AI 构建自定义场和效果器。
从 Cinema 4D 复制并粘贴到 Autograph
现在,您可以将摄像机、灯光、基础体、平面、文本、空对象及其位置、旋转和缩放动画从 Cinema 4D 复制并粘贴到 Autograph。动画会逐帧烘焙,因此由表达式、MoGraph、约束或绑定驱动的运动,在导入后可与视口播放效果保持一致。静态值会导出为常量。标准和 Redshift 摄像机及灯光均受支持。MoText 和文本样条会转换为 Autograph 原生的可编辑文本图层,不受支持的对象则会转换为空对象。
工作流程与界面
标签分组
对象管理器中的新按钮可将对象的标签折叠为可视化分组,同时保留原有的标签顺序。将鼠标悬停在分组上可查看其中的标签数量。单击分组可打开列表,您可以从中选择标签、将标签拖出,或按 Esc 关闭列表。您还可以拖放整个分组,快速调整标签顺序。过滤器管理器可控制哪些类型的标签参与分组。Phong 等只能存在一个的标签不会被分组。
标签内容预览
现在,无需将对象转为可编辑对象,即可在视口中查看标签内容。支持预览多边形、边和点选集、顶点贴图、顶点颜色及软选择。此功能也适用于程序化选集,包括基础体和生成器上的选集,让您在后续操作使用选集之前,先确认其实际覆盖范围。在标签分组列表中,将鼠标悬停在标签上即可预览。对于单个标签,或禁用分组时,则需要选中标签才能预览。新增的偏好设置可调整高亮颜色及其不透明度。
工具提示
选定工具后,HUD 现在会显示该工具的使用方法,包括修饰键、鼠标按钮及组件模式限制。您可以通过 HUD 左上角的箭头折叠或展开提示,此设置对所有工具生效。
随机对象颜色显示模式
新增的视口显示模式可为每个对象显示不同的颜色,而不会覆盖其原有的显示颜色,让复杂场景中的对象区分一目了然。您可以在视口设置(Shift+V)或“视图”菜单中启用“随机着色”。
显示被遮挡的选中组件
现在,即使选中的组件被同一网格的其他多边形或其他对象遮挡,也会显示出来。新增的偏好设置可调整被遮挡组件的不透明度,默认值为 10%,设置为 0% 则关闭显示。您也可以通过视口菜单或视图设置切换此功能。
CAD 导入
CAD 导入现已支持 Windows ARM,并新增以下格式:3MF/AMF(.3mf、.amf)、3D Experience(.3dxml)、CREO(.xpr、.xas、.neu)、IFC(.ifc)、Inventor(.ipt、.iam)、NX(.prt)和 Solid Edge(.par、.asm、.psm)。这些格式与原有的 Catia V5、Open JT、IGES、STEP 和 SolidWorks 支持一同提供。
纹理重采样
Commander 中新增的命令可在形状相似但 UV 布局完全不同的两个对象之间转移纹理和材质。该功能专门用于将高面数、拓扑不佳的网格外观转移到重构网格生成器的输出上,适用于“传递属性”无法有效处理的情况。您可以通过立方体或基于角度的投射方式生成新的 UV,也可以使用现有 UV。重采样后的纹理会以 resampled_ 为前缀写入指定的输出目录,源材质的副本则会应用到目标对象上。
弯曲变形器的强度与旋转手柄
强度和旋转现已分别控制。您可以通过可拖动的控制带设置变形方向,强度手柄会沿该方向移动,HUD 则显示当前角度。按住 Shift 可按照建模设置中的步长调整角度,旋转角度不再受限。
Redshift 2027.0
高级 GPU 内存架构
新的显存管理架构提供更精细的内存分配,改善与其他 GPU 加速应用之间的 GPU 资源共享,增强统一内存支持,并支持在多个 GPU 上并行加载场景。预计配备大容量显存的 GPU、统一内存架构和多 GPU 系统将获得最明显的提升。
Redshift for Cinema 4D 性能
Redshift for Cinema 4D 的多个环节均进行了性能优化。首个像素出现前的等待时间和场景更新耗时均大幅缩短,视口 IPR 在日常工作中的响应也更加流畅。
Redshift Fur
这套程序化系统可在渲染时直接为任意网格生成毛皮、纤维、机织织物和针织材质,无需创建专用几何体。支持运动模糊、实例、UV 控制和 Redshift 材质。
Redshift Live 增强
着色器编译速度更快,并新增对折射、透明阴影、区域灯光扩散角度及光线追踪景深的支持,使 Redshift Live 的显示效果更接近最终渲染。
NVIDIA RTX Spark 支持
Redshift 工作流程现已扩展至 NVIDIA RTX Spark 设备。
Cinema 4D 工作流程改进
- 节点编辑器拖放。将 Redshift 材质拖入 Redshift 节点编辑器,即可创建与该材质关联的引用节点;拖入顶点颜色或顶点贴图标签,则会创建以该标签命名的顶点属性节点,并仅显示适用的输出端口(outColor 或 outScalar)。
- 材质标签中的三平面映射与六边形平铺。您现在可以通过 Cinema 4D 的材质标签使用这些 Redshift 功能,为每个对象单独调整 UV Context 设置,无需复制材质,也无需将投射设置固定在材质内部。这有助于修正纹理拉伸,并减少明显的重复图案。
- Redshift 摄像机自动对焦。在您浏览场景时,焦点会自动调整。
- 色彩管理。新增 ACES 2 支持,并改善色彩空间处理的一致性,与 Cinema 4D 端的 OCIO 更新保持同步。
其他小型功能、变更与改进
- OCIO 已更新至 ACES 2.0。
- 移除了位图、MoGraph 颜色和顶点贴图着色器中的“自动”模式。载入使用 2026.4.0 之前版本创建的场景时,“自动”模式会转换为明确指定的模式。
- 色彩空间名称现在会与索引一同保存在场景中,因此配置发生变化时,索引会根据名称相应更新。
- 色彩空间列表现在按照配置文件中的顺序排列,不再按字母顺序排序,以便将重要的色彩空间置于列表顶部。
- 色彩空间按类别分组,菜单顶部会列出常用色彩空间。自定义配置可将色彩空间指定到常用类别。
- 新增
$take_hierarchy标记,可插入 Take 的完整层级名称,各级名称以下划线连接,而非仅插入当前 Take 的名称。 - 新增
$takeparent#标记,可返回上级 Take 的名称,其中#指定向上追溯的层级数。如果该层级不存在上级 Take,则返回“unresolved”。 - “保存所有 Take 及资产”现在始终使用包含层级信息的 Take 名称作为目标文件夹名称,以减少重名冲突。
- 新增自动 Take 启用时的视口边框界面颜色。
- 节点编辑器搜索现在不仅会淡化节点,还会淡化连线、注释、重路由节点和框架,并自动调整视图以显示搜索结果。
- 材质节点编辑器的独显模式会淡化独显节点上游之外的所有节点,并以橙色粗边框标示独显节点。
- 端口检查器和数据检查器现在可用于场景节点中未连接的端口,不再显示“未激活”。
- 改进了桥接工具的曲率计算,使桥接形状更加接近圆弧。
- UV 矩形化现在可一次处理多个矩形多边形区域,并报告无法处理的 UV 岛。
错误修复
动画
- 修复了关键帧精简器在 Cappucino 轨道上生成重复关键帧并导致切线异常的问题。
资产浏览器
- 修复了禁用资产预览后,资产浏览器中的预览图标看似消失的问题。
属性管理器
- 修复了在用户数据管理器列表中按住 Shift 无法选择多个条目的问题。
- 修复了保存默认预设后,属性管理器的预设下拉菜单显示为空的问题。
- 修复了更改旋转顺序后,属性管理器未刷新的问题。
- 修复了对多个选中对象使用公式时,“混合”状态被清除并产生错误随机值的问题。
BodyPaint
- 修复了投射绘制过程中 UV 视口崩溃,导致绘制纹理无法正确加载的问题。
摄像机对象
- 修复了摄像机变形器笔刷在视口中处于闲置状态时,半径显示不正确的问题。
- 修复了使用 Redshift 作为渲染引擎时,默认编辑器摄像机被设为 Ocamera 而非 Orscamera 的问题。
角色动画
- 修复了创建角色模板时,因绑定组件名称镜像设置不正确或名称重复而导致崩溃的问题。
色彩管理
- 修复了使用经典 OCIO 时,图片查看器导出的文件保存为线性色彩而非 sRGB 的问题。
变形器
- 修复了弯曲变形器旋转手柄导致角度值意外跳变的问题。
- 修复了涉及生成器、修改器和渲染的多种对象及变形器操作中的崩溃问题。
- 修复了弯曲变形器旋转手柄在正交视图中无法正常工作的问题。
- 修复了 FFD 变形器的“适合父级”未能完全包围平面对象的问题。
交换
- 修复了导入某些包含无效 UV 数据和 N-gon 的 USD 文件时发生崩溃的问题。
FBX
- 修复了导入某些 FBX 文件时发生崩溃的问题。
毛发
- 修复了根据样条生成的毛发对象在视口动画中无法正确更新的问题。
- 修复了某些动力学设置中毛发闪烁且无法正确跟随引导线的问题。
- 修复了添加引导线工具在几何体的错误部位生成多余毛发引导线的问题。
帮助内容
- 修复了法线编辑菜单中的“显示帮助”打开错误帮助页面的问题。
界面
- 修复了使用“图标下方显示文本”模式时,雕刻细分选项的齿轮图标消失的问题。
- 修复了打开场景时内存占用过高并随后崩溃的问题。
- 修复了生成器面板中缺少植物生成器的问题。
- 修复了多显示器环境下 Cinema 4D 主窗口在错误显示器上打开的问题。
- 修复了“恢复为已保存版本”确认对话框提供冗余选项的问题。
- 修复了加载已保存的参数数据时显示错误警告信息的问题。
- 修复了执行面板的“关闭”和“取消停靠”命令后,视口被禁用且无法正常工作的问题。
- 修复了材质管理器、UV 编辑器等管理器在停靠布局中重叠的问题。
- 修复了 Bitmap Bool 图标在其对应选项被禁用时未变灰的问题。
- 修复了图片查看器中缺少“适应图像”选项的问题。
- 修复了某些情况下不支持相关命令,却仍可使用“创建脚本”的问题。
- 修复了使用 macOS 菜单栏时,“窗口”菜单图标缺失的问题。
- 修复了树状视图下拉菜单中的文本被截断的问题。
- 修复了系统日期和时间设置导致日期控件中的日历标题错位的问题。
- 修复了 macOS 中“退出 Cinema 4D”和“退出并释放许可证”菜单项顺序错误的问题。
字距调整
- 修复了居中和右对齐的等宽文本对象在动画过程中发生意外偏移的问题。
建模
- 修复了禁用“实时切割”时,移动切割线后平面切割预览消失的问题。
- 修复了对称节点生成的镜像几何体出现缺失多边形和孔洞的问题。
- 修复了循环切割预览在透视视图中显示不正确的问题。
- 修复了 LOD 级别在视口中未根据摄像机距离正确更新的问题。
- 修复了样条画笔的自动吸附未将点放置在正确吸附位置的问题。
- 修复了 Windows 中缩放后的高 DPI 显示环境下,挤压及相关工具响应不正确的问题。
- 修复了在正交视图中无法选择平面切割移动手柄的问题。
- 修复了测量与构造的更新延迟,需进一步操作视口才会更新的问题。
- 修复了循环切割和路径切割无法处理与 N-gon 相连的多边形的问题。
- 修复了多边形选区的建模轴位置不正确的问题。
- 修复了场景中启用倒角变形器时吸附行为不正确的问题。
- 修复了某些含有无效几何体的 3D 扫描网格无法吸附的问题。
- 修复了对已加载的贝塞尔对象进行点编辑时,撤销和重做无法正常工作的问题。
- 修复了场景中存在被编辑网格的实例时,软选择预览缺失的问题。
- 修复了图案选择和 Phong 断开选择未考虑隐藏多边形的问题。
- 修复了使用撤销后,顶点绘制工具在各绘制模式下仍会绘制隐藏几何体的问题。
- 修复了建模操作期间发生崩溃的问题。
- 修复了使用软选择或非绘制类笔刷时,“.”快捷键和笔刷缩放异常的问题。
- 修复了拖动端点时测量工具未实时更新的问题。
- 修复了多个实例在“对象”显示模式下引用同一对象时发生崩溃的问题。
- 修复了使用顶点贴图衰减模式时,不适用的软选择参数仍可编辑的问题。
- 修复了使用样条画笔双击点时发生崩溃的问题。
- 修复了路径选择功能在边模式下无法创建或更新选集标签的问题。
- 修复了网格检查器将某些 N-gon 错误报告为非平面多边形的问题。
- 修复了矩阵挤压在视口中拖动时不支持负值的问题。
- 修复了笔刷工具尺寸不稳定,以及视口拖动输入过于敏感的问题。
- 修复了网格检查将多边形边缘高亮为错误多边形,而未高亮实际受影响多边形的问题。
- 修复了细分包含顶点贴图和过期 UV 数据的对象时发生崩溃的问题。
- 修复了布尔运算中 NaN 或无穷大等无效点数据导致崩溃的问题。
- 修复了网格偏离世界原点时,对称平面在局部空间中闪烁的问题。
MoGraph
- 修复了打开某些包含不受支持插件数据的旧版场景时发生崩溃的问题。
- 修复了自引用 MoGraph 样条设置未正确计算的问题。
- 修复了克隆对象在“步进”模式下,“结束”参数未重新映射克隆分布的问题。
- 修复了使用样条分布的矩阵对象在切换视口可见性后消失的问题。
- 修复了在某些旧版场景中拖动时间轴时发生崩溃的问题。
- 修复了为带有置换的细分几何体生成缓存时发生崩溃的问题。
Neutron
- 修复了无法将记忆节点组更改为 Loop Carried Value 的问题。
- 修复了节点图中的实例节点未实时更新的问题。
- 修复了节点修改器中的记忆节点无法跨对象层级正常工作的问题。
- 修复了 Sum Stream 和 Aggregate 节点在检查器中显示错误值的问题。
- 修复了多个 Greeble 节点使用同一选集时,在各变形器之间未正确计算的问题。
- 修复了变换子对象层级中的对象时,节点样条生成器未更新的问题。
- 修复了节点效果器或修改器中的 Object Child 端口未正确识别子对象的问题。
- 修复了启用“仅迭代选中项”后,点修改器无法修改几何体的问题。
- 修复了节点变形器处理高密度几何体时过于缓慢的性能问题。
节点编辑器
- 修复了节点编辑器中拖放连线时弹出的菜单内,端口顺序不正确的问题。
对象管理器
- 修复了涉及 Redshift 材质和纹理的撤销操作或材质预览更新过程中发生崩溃的问题。
对象
- 修复了打开某些包含 SDS 对象的恢复场景文件时发生崩溃的问题。
- 修复了撤销贝塞尔对象的网格点更改后,对象从视口中消失的问题。
其他
- 修复了补间工具在视口重绘过程中处理鼠标输入而导致不稳定的问题。
- 修复了旧版场景保存带递增编号的渲染文件,而未提示是否覆盖现有文件的问题。
- 修复了脚本日志生成包含多余子 ID 的无效 CallCommand 条目的问题。
- 修复了打开或操作某些包含材质的场景文件时发生崩溃或无响应的问题。
- 修复了在场中编辑渐变或曲线形状时发生崩溃的问题。
- 修复了展开工具提示时,创建轮廓和样条横截面工具发生崩溃的问题。
- 修复了对包含固定 UV 的网格执行 UV 展开、松弛或重置并展开时发生崩溃的问题。
- 修复了对单个多边形或其他无效选区执行 ABF UV 松弛或展开时发生崩溃的问题。
- 修复了将节点效果器作为变形器使用时发生崩溃的问题。
- 修复了某些场景停止播放后因越界访问而发生崩溃的问题。
模拟
- 修复了在模拟场景中将渲染引擎从标准切换为 Redshift 时发生崩溃的问题。
Take 系统
- 修复了选择或取消选择 Take 时,Take 系统生成不正确撤销记录的问题。
- 修复了取消图片查看器中的“渲染标记的 Take”渲染时无响应的问题。
- 修复了删除控制 Redshift 材质参数的 Take 时,出现极长延迟或无响应的问题。
Team Render
- 修复了渲染完成后,Team Render 进度指示器仍停留在 100% 的问题。
Team Render Server
- 修复了 Team Render Server 更新网络负载状态时,在控制台中触发已弃用 API 警告的问题。
UV 工具
- 修复了使用栅格化排列后,包围盒 UV 排列结果不正确的问题。
- 修复了对某些高面数网格进行 UV 松弛时,结果出现变形的问题。
- 修复了在某些场景中展开 UV 时发生崩溃的问题。
- 修复了在 UV 编辑模式下执行各种 UV 编辑和纹理绘制操作时发生崩溃的问题。
- 修复了在 UV 编辑器或 BodyPaint 工作流程中创建新纹理时发生崩溃的问题。
- 修复了对选中区域中包含不相连面的网格执行 UV 矩形化时发生崩溃的问题。
- 修复了在世界坐标模式下缩放 UV 时,V 轴无法正常缩放的问题。
- 修复了重新打开某些由 WRL 文件转换而来的场景时发生崩溃的问题。
顶点颜色
- 修复了平滑功能无法正确作用于样条顶点贴图的问题。
视口
- 修复了相同的权重标签在属性管理器中显示不正确权重值的问题。
- 修复了 Cinema 4D 崩溃后重新启动时,视口仍为空白或无响应的问题。
- 修复了视口中的 HUD 参数未正确更新的问题。
- 修复了移动摄像机时,交互式渲染区域未正确更新的问题。
- 修复了在视口中切换背面剔除时发生崩溃的问题。
体积
- 修复了体积生成器的半径值未正确随缩放调整的问题。
评论
0 条评论
文章评论已关闭。