Error: Status -1 -- My installation failed with this error message

Doug Y
Doug Y
  • Updated

If an installation fails relaying status -1, it's typically related either to file permission issues between the installer and the locations it's trying to install files into, or a background service that's interrupting the installation process. Since there are multiple possible culprits, there's multiple potential workarounds. Here they are in order of ease.

Reset Configuration

  • Click Reset Configuration in the Maxon App's top right menu before attempting a reinstall, then log out of your Maxon account.
    resetconfig.jpg
  • Restart your machine, log back into your Maxon account, and try the installation once more.
    • This force-closes any background service that might've been interrupting the installer.

Run an uninstaller script

  • Run an uninstallation script, then try reinstalling:
    • Mac:
      Close the installer. Head to Applications > Utilities > Terminal
      • run the command sudo /Library/Application\ Support/Maxon/Tools/uninstall-maxon-service.sh
    • Windows:
      Close the installer. Locate the following, right-click and run as admin:
      C:\Program Files\Red Giant\Services\uninstall-maxon-service.bat 

Reinstalling with new admin

  • Create a brand new user account on your machine with admin permissions, and try reinstalling under that new account.

Remove previous installation manifests

Mac – /Users/Shared/Red Giant/.rgdeploy/history
Windows – C:\ProgramData\Red Giant\.rgdeploy\history

In those folders, you will find manifest files dropped by the installer you should remove, with names like:
com.redgiant.application-manager_v1.2.1_rgmanifest.xml
com.redgiant.service_v1.2.1_rgmanifest.xml
com.redgiant.service_v1.5.0_rgmanifest.xml
net.maxon.app-manager_v1.0.0_rgmanifest.xml

 

Bypass Quarantine (Red Giant Application Manager Mac-only) 

Newer versions of MacOS, such as Big Sur, have a stronger quarantine function for downloaded files. 

 

Diagnosis:

  • Using Terminal, run this command on the RGA Installer app bundle
    • xattr {path to RGA Installer}
  • among the attributes listed, you should see “com.apple.quarantine”

 

Resolution:

  • remove the quarantine flag from the RGA Installer app bundle, using this command
    • sudo xattr -r -d com.apple.quarantine {path to RGA Installer}
  • re-run the xattr command and it should show that the quarantine flag is no longer present

 

If none of those steps help, or you need assistance, please contact support.

 

Related FAQs:

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