Team Render とは
Team Render は、Cinema 4D に標準搭載されている分散レンダリングシステムです。ネットワーク上の複数のコンピューターにレンダリング処理を分散することで、ローカルマシン単体よりも高速にレンダリングを完了できます。
Team Render 環境では、各マシンは次のいずれかの役割を担います。
- ジョブを配信する【ホスト】
- 実際のレンダリングを実行する【クライアント】
Cinema 4D はホストとしてもクライアントとしても動作できます。
一方、スタンドアロンアプリケーションである Team Render Server(TRS)は常にホストとして動作し、専用のジョブキューや Web ベースの管理画面を提供します。
また、Team Render Client は常にクライアントとして動作します。
これらのホスト方式はいずれも同じ接続システムを利用しているため、本ガイドで紹介するトラブルシューティング手順は、特別な記載がない限り Team Render Server と Cinema 4D の両方に共通して適用できます。
Team Render の問題は、一見すると原因が分かりにくい場合があります。
例えば以下のような症状が発生することがあります。
- クライアントがマシン一覧から消える
- ジョブがキューに入ったまま進行しない
- レンダリング結果の色が正しくない
- Team Render Client のコンソールが起動しない
本ガイドでは、サポートチームでよく見られる代表的な問題について、その原因と解決方法を解説します。
初めて Team Render を設定する場合で、まだ接続の確立自体ができていない場合は、まず以下の記事をご参照ください。
How to setup Team Render
その後も問題が解決しない場合は、本ガイドを参考にしてください。
トラブルシューティングを始める前に
事前確認項目
Team Render の問題の多くは、以下の 4 つの要因に起因しています。
個別のトラブルシューティングに進む前に、まず以下を確認してください。
バージョンの一致
ホストとクライアントは、必ず同じビルドを使用する必要があります。
バージョンの不一致は Team Render の問題として最も多い原因のひとつです。
各マシンで以下を確認してください。
Help > About
また、Redshift のバージョンも一致している必要があります。
異なるバージョンを使用している場合、「Out of Memory」エラーが発生することがあります。
プラグイン
シーンで使用しているサードパーティ製プラグインは、すべての Team Render Client にインストールされている必要があります。
ネットワーク接続
Wi-Fi 環境でも動作する場合がありますが、有線接続を推奨します。
サーバーとクライアントは、同一ネットワークまたは相互通信可能なネットワーク上に存在している必要があります。
また、Bonjour による自動検出は VLAN や多くの VPN ブリッジ環境を越えて動作しません。
ファイアウォールおよびウイルス対策ソフト
以下のアプリケーションは、双方向通信が許可されている必要があります。
- Cinema 4D
- Team Render Server
- Team Render Client
- Bonjour
デフォルトでは、以下のポートを使用します。
| アプリケーション | ポート |
|---|---|
| Cinema 4D | 5400 |
| Team Render Client | 5401 |
| Team Render Server | 5402 |
自動検出機能には以下も必要です。
| サービス | ポート |
|---|---|
| Bonjour | UDP 5353 |
| SSDP | UDP 1900 |
一部のセキュリティソフトでは、Team Render 通信に対して個別の許可設定が必要になる場合があります。
まずはコンソールを確認してください
Team Render Server と Team Render Client は、実行中に発生した警告やエラーをコンソールに出力します。
以下のような問題が発生した場合、
- 接続切断
- レンダリング失敗
- プラグイン読み込みエラー
- 認証エラー
その原因がコンソールに記録されていることがあります。
個別のトラブルシューティングを始める前に、まずホスト側とクライアント側のコンソールを確認してください。問題の原因がすでに表示されている場合があります。
ワンポイント
Team Render のマシンリストは必ずバックアップしましょう
Team Render Server を利用している場合でも、Cinema 4D をホストとして利用している場合でも、構成変更後はマシンリストを保存しておくことをおすすめします。
例えば以下のような変更を行った後です。
- 新しいクライアントの追加
- マシン名の変更
- セキュリティトークンの変更
マシンリストはホストアプリケーションの Preferences フォルダ内に保存されます。
Preferences が破損したり削除された場合、登録済みのマシン情報も失われます。
事前に .txt ファイルとして保存しておけば、再設定を行うことなく簡単に復元できます。
Team Render Server で保存する場合
Machine メニューから以下を選択します。
Machine > Save Machines...
保存先を指定して .txt ファイルを保存してください。
Cinema 4D で保存する場合
以下を開きます。
Render > Team Render Machines
その後、
Machine > Save Machines...
を選択して保存してください。
よくある問題と解決方法
Team Render Client または Team Render Server が起動しない
症状
Team Render Client または Team Render Server を起動すると、一瞬スプラッシュ画面が表示された後、アプリケーションが開きません。
再度起動しようとしても何も起こらなかったり、起動はするものの毎回同じ問題が発生する場合があります。
確認事項
1. バックグラウンドで既に起動していないか確認する
アプリケーションが既に実行中である可能性があります。
Windows の場合:
- タスクマネージャーを開く
- 「Team Render Client.exe」または「Team Render Server.exe」を探す
macOS の場合:
- アクティビティモニタを開く
- 「Team Render」を検索する
実行中の場合はプロセスを終了し、再度起動してください。
2. Preferences をリセットする
プロセスが存在しないにもかかわらず起動できない場合、Preferences の破損が原因である可能性があります。
その場合は Preferences の削除またはリセットをお試しください。
Team Render Client の Preferences を削除する方法
1
バックグラウンドで Team Render Client が起動している場合は終了します。
2
Maxon フォルダを開きます。
Windows
Users\USERNAME\AppData\Roaming\MaxonmacOS
Users/USERNAME/Library/Preferences/Maxonショートカット方法:
Cinema 4D を起動し、
Edit > Preferences > Open Preferences Folderを選択します。
その後、一つ上の階層へ移動すると、Maxon 関連フォルダが表示されます。
3
Team Render Client のフォルダを削除します。
以下のような名前になっています。
Maxon Cinema 4D 202X_xxxxxxxx_c末尾の
_cは Team Render Client を表します。
なお、xxxxxxxx の部分は環境ごとに異なるランダム文字列です。
4
Team Render Client を再起動します。
起動時に新しい Preferences フォルダが自動生成されます。
Team Render Server の Preferences を削除する方法
注意
Team Render Server の Preferences を削除すると、登録済みのマシンリストも削除されます。
事前に
Machine > Save Machines...でバックアップしている場合は、後から再読み込みできます。
バックアップがない場合は、すべてのクライアントを再登録する必要があります。
1
Team Render Server を終了します。
2
以下のフォルダを開きます。
Windows
Users\USERNAME\AppData\Roaming\MaxonmacOS
Users/USERNAME/Library/Preferences/Maxon3
以下のフォルダを削除します。
Maxon Cinema 4D 202X_xxxxxxxx_s末尾の
_sは Team Render Server を示します。
4
Team Render Server を再起動します。
新しい Preferences フォルダが自動生成されます。
5
事前にバックアップしたマシンリストがある場合は再読み込みします。
Machine > Load Machines...を選択し、保存済みの .txt ファイルを読み込んでください。
バックアップがない場合は、
Machine > Add Machine...を使用して各クライアントを再登録してください。
注意:誤ったフォルダを削除しないでください
Maxon フォルダ内には複数のアプリケーション用 Preferences が保存されています。
問題が発生しているアプリケーションのフォルダのみ削除してください。
| サフィックス | アプリケーション |
|---|---|
| なし | Cinema 4D |
| _c | Team Render Client |
| _s | Team Render Server |
| _w | Cineware |
| _x | Command Line |
| _p | c4dpy |
誤ったフォルダを削除すると、別のアプリケーションの設定まで失われる可能性があります。
接続できない場合:ロールを入れ替えて接続をリセットする
症状
ホスト側の Cinema 4D が Team Render Client に接続できない。
例えば以下のような状況です。
- Verify に失敗する
- クライアントが緑色にならない
- 接続直後に切断される
- 何もエラーが出ず接続できない
Team Render サポート案件の中でも、接続トラブルは最も多い問題です。
開発チームで正式に原因が特定されているわけではありませんが、実際のサポート事例では、以下の「ロール入れ替え手順」によって解決したケースが数多くあります。
考えられる要因として、Cinema 4D や Team Render Client が保持している内部接続状態がリセットされることが挙げられます。
方法 1:簡易ロールスワップ
1
現在 Cinema 4D を実行しているホストマシンで Cinema 4D を終了し、代わりに Team Render Client を起動します。
2
現在 Team Render Client を実行しているワーカーマシンで Team Render Client を終了し、代わりに Cinema 4D を起動します。
3
ワーカーマシン側の Cinema 4D から、ホスト側で起動している Team Render Client に接続および Verify を行います。
4
成功・失敗に関係なく、両方のアプリケーションを終了します。
5
元の構成に戻します。
- ホスト → Cinema 4D
- ワーカー → Team Render Client
再度接続を試してください。
この手順だけで問題が解決するケースがあります。
方法 2:Team Render Server を利用した接続リセット
方法 1 で改善しない場合は、こちらの方法をお試しください。
こちらは Team Render Server(TRS)を利用して接続状態をリセットする手順です。
サポート事例では、特に頑固な接続トラブルに対して効果が確認されています。
1
ワーカーマシンで Team Render Server を起動します。
ホストマシンでは Team Render Client を起動します。
その状態で Verify および接続を行います。
この「逆転した構成」で接続できるか確認してください。
2
両方のアプリケーションを終了します。
その後、本来の構成に戻します。
ホスト:
Team Render Serverワーカー:
Team Render Client再度 Verify と接続を実行します。
3
最後にホスト側の Team Render Server を終了し、Cinema 4D を起動します。
通常、この時点で Team Render Client が Cinema 4D のマシン一覧へ正常に表示され、接続できるようになります。
この方法で改善した場合は、サポートへ報告する際にぜひお知らせください。
同様の事例を収集することで、根本原因の特定につながる可能性があります。
Team Render Machines にクライアントが表示されない
症状
Team Render Server または Cinema 4D の Team Render Machines を開いても、クライアントが表示されません。
クライアントマシン自体は起動しており、Team Render Client も実行中です。
確認事項
1. ネットワーク構成を確認する
ホストとクライアントが同一ネットワーク上に存在することを確認してください。
有線・無線の混在は問題ありませんが、同一サブネット内で通信できる必要があります。
2. Bonjour のアナウンス設定を確認する
すべてのマシンで以下が有効になっていることを確認してください。
- Announce Service via Bonjour
- Announce Service to Local Network
設定場所:
Team Render Client / Team Render Server
File > PreferencesCinema 4D
Render > Team Render Machines
Machine > Preferences
3. Windows では Bonjour がインストールされているか確認する
Bonjour が削除されている場合や未インストールの場合、自動検出が機能しません。
必要に応じて以下から再インストールしてください。
- iTunes
- Bonjour Print Services for Windows
4. ファイアウォールを確認する
以下のポートが双方向で許可されている必要があります。
| サービス | ポート |
|---|---|
| Bonjour | UDP 5353 |
| SSDP | UDP 1900 |
また、
- Cinema 4D
- Team Render Client
についても個別に許可ルールを作成してください。
5. 手動接続を試す
Bonjour による自動検出が機能しない場合は、自動検出を無効化し、IP アドレスで直接接続する方法をお試しください。
詳細は次のセクションをご参照ください。
自動検出を無効にして手動接続する
この方法を試すべきケース
Bonjour による自動検出は便利ですが、接続トラブルやレンダリング時の不安定な動作の原因になることがあります。
原因不明の接続問題が発生している場合は、手動接続へ切り替えて検証することを推奨します。
デフォルトポート番号
| アプリケーション | ポート |
|---|---|
| Cinema 4D | 5400 |
| Team Render Client | 5401 |
| Team Render Server | 5402 |
※これらは Team Render Preferences から変更可能です。
手動接続の設定手順
1
すべてのマシンで以下を無効化します。
- Announce Service via Bonjour
- Announce Service to Local Network
Team Render Client / Team Render Server
File > PreferencesCinema 4D
Render > Team Render Machines
Machine > Preferences
2
同じ設定画面で Security Token を確認します。
後ほどホスト側でクライアントを登録する際に必要になります。
3
ホスト側で Team Render Machines を開きます。
Cinema 4D
Render > Team Render MachinesTeam Render Server
メイン画面を使用します。
4
Add Machine を使用してクライアントを追加します。
形式:
IPアドレス:ポート番号または
ホスト名:ポート番号例:
192.168.1.12:5401ポート番号は以下を使用します。
| 接続先 | ポート |
|---|---|
| Cinema 4D | 5400 |
| Team Render Client | 5401 |
Cinema 4D
Machine > Add MachineTeam Render Server
Machine > Add Machineまたは
+ ボタン
5
Security Token の入力を求められたら、クライアント側で確認した値を入力します。
認証に成功すると、マシン一覧が緑色表示になります。
6
必要なすべてのクライアントについて同じ作業を繰り返します。
運用上の推奨事項
DHCP により IP アドレスが変更されると、手動登録したクライアントが接続できなくなる場合があります。
そのため以下のいずれかを推奨します。
- DHCP Reservation を設定する
- 固定 IP を使用する
- ホスト名で登録する
特にホスト名による接続は、LAN 環境で名前解決が正しく動作している場合に有効です。
クライアントが「No Answer」になる
症状
クライアントは一覧に表示されているものの、
No Answerの状態になり応答しません。
Team Render Client 自体は正常に起動しています。
確認事項
1. コンソールログを確認する
まず Team Render Client のコンソールを確認してください。
以下のような情報が記録されます。
- Verify 失敗
- Security Token 不一致
- 接続拒否
- ハンドシェイク失敗
Team Render Server を利用している場合は、Web UI 側にも同様のエラーが表示されます。
まずはログを確認し、原因を特定してください。
2. ファイアウォール
最も多い原因のひとつです。
以下を確認してください。
- クライアント側で送信通信がブロックされていないか
- ホスト側で受信通信がブロックされていないか
また、
- Cinema 4D
- Team Render Client
が許可リストへ登録されていることを確認してください。
3. Security Token の不一致
全マシンで同じ Security Token が設定されている必要があります。
確認場所:
Team Render Client / Team Render Server
File > PreferencesCinema 4D
Render > Team Render Machines
Machine > PreferencesToken を変更した場合は、再度 Verify を実行してください。
4. IP アドレスの変更
IP アドレス指定でクライアントを登録している場合、
DHCP によって IP が変更されると接続できなくなります。
対処方法:
- 現在の IP へ更新する
- ホスト名で登録し直す
5. ローカルマシン自身が応答しない
サーバー自身のローカルクライアントが応答しない場合、
127.0.0.1へのアクセスがファイアウォールによってブロックされている可能性があります。
localhost の通信ルールを確認してください。
複数 Client をインストールしているのに 1 台しか表示されない
症状
複数の Team Render Client を運用しているにもかかわらず、サーバー上には 1 台しか表示されません。
原因
ほぼ確実にクローン環境です。
例えば、
- ディスクイメージのコピー
- OS クローン
- 仮想マシン複製
などで Cinema 4D を複製した場合、すべてのクライアントが同じ内部 Client ID を持つことがあります。
その結果、Team Render は同一マシンとして認識してしまいます。
解決方法
各クライアントで Team Render Client の Preferences を削除してください。
再起動時に新しい Client ID が生成されます。
削除対象
Maxon Cinema 4D 202X_xxxxxxxx_c削除後
- Team Render Client を再起動
- サーバー側で Verify を実施
これで別々のクライアントとして認識されるようになります。
今後同じ問題を防ぐには
マスターイメージを作成する前に、
_cフォルダを削除しておくことを推奨します。
そうすることで、各クローン環境が初回起動時に固有の Client ID を生成します。
クライアントが消える/Unknown Error が表示される
症状
昨日まで正常だったクライアントが突然
Unknown Errorになる。
または一覧から消えたり、別のマシンとして再登録されたように見える場合があります。
原因
DHCP による IP アドレス変更が原因であるケースがほとんどです。
IP アドレスで登録していた場合、古いアドレスへの参照が残り続けるため接続できなくなります。
解決方法
1
Machines リストで対象クライアントをダブルクリックします。
2
現在の IP アドレスへ更新します。
3
長期的には以下を推奨します。
- DHCP Reservation
- 固定 IP
- ホスト名による接続
Team Render Server のフォルダを移動または名称変更した後、すべてのクライアントが接続できなくなった
症状
これまで正常に動作していた Team Render Server が、Cinema 4D または Team Render Server のインストールフォルダを移動・名称変更した後から、すべてのクライアントと接続できなくなります。
既存クライアントの Verify を実行しても失敗します。
原因
Team Render Server の識別情報はインストールパスと関連付けられています。
そのため、インストールフォルダの場所や名前を変更すると、過去に認証済みだったクライアント情報が無効になり、再認証できなくなる場合があります。
解決方法
1
Team Render Server 側で既存のクライアントをすべて削除します。
2
クライアント側で接続情報をリセットします。
必要に応じて Team Render Client の再インストールも行ってください。
3
すべてのクライアントを再登録し、再度 Verify を実行してください。
クライアントは接続済みなのにレンダリングが開始されない
症状
すべてのクライアントが緑色で正常接続状態になっているにもかかわらず、レンダリングジョブを送信してもフレームの計算が開始されません。
ジョブがキューに残ったままになる、またはローカルマシンのみがレンダリングを行う状態です。
確認事項
1. 最初にコンソールログを確認する
まずは Team Render Client のコンソールを確認してください。
以下のような問題はコンソールへ記録されます。
- プラグインの読み込み失敗
- アセット不足
- ライセンスエラー
- レンダラーの初期化失敗
- 非対応レンダラーへのフォールバック
Team Render Server を利用している場合は、Web インターフェース側のジョブログにも同様の情報が表示されます。
多くの場合、原因はログ内に直接記録されています。
2. プラグインの一致を確認する
シーンで使用しているすべてのプラグインが、すべてのクライアントに同じバージョンでインストールされている必要があります。
特に Redshift は、ホストとクライアントで完全に同じバージョンでなければなりません。
3. ライセンス数を確認する
利用している Team Render Client 数が契約ライセンス数を超えていないか確認してください。
ライセンス数を超過しているクライアントはレンダリングに参加できません。
4. アセットへのアクセス権を確認する
以下のファイルへすべてのクライアントがアクセスできる必要があります。
- テクスチャ
- Simulation Cache
- Alembic ファイル
- IES ファイル
- 外部参照ファイル
推奨方法:
File > Save Project with Assetsこれにより必要なアセットをまとめて保存できます。
アセットが見つからない場合はコンソールへエラーが記録されます。
5. シミュレーションをベイクする
以下のようなシミュレーションは事前にベイクしてください。
- Dynamics
- Particles
- Cloth
- その他物理シミュレーション
未ベイクの状態では、マシンごとに異なる結果になる可能性があります。
6. 表示状態が実際と異なる場合がある
稀に Team Render Machines の表示が正しく更新されないことがあります。
画面上では「レンダリングしていない」ように見えても、実際には処理が進行しているケースがあります。
正確な状態は Team Render Server のログで確認してください。
7. 手動接続へ切り替えてみる
原因が特定できない場合は、
「自動検出を無効にして手動接続する」
の手順を試してください。
Bonjour の自動検出がレンダリング時の問題を引き起こしているケースがあります。
Team Render のレンダリング結果の色が異なる
症状
Team Render Server でレンダリングした結果が、ローカルレンダリングと比較して以下のように見える場合があります。
- 色が薄い
- 彩度が高い
- 明るさが異なる
- 全体の色味が違う
原因
Cinema 4D の新しい OCIO カラーマネジメントと Team Render Server の組み合わせで発生する既知の問題です。
回避方法
プロジェクトの Color Space を
Legacy (sRGB Linear)へ変更してください。
これにより Redshift 側のカラーマネジメントが使用され、Team Render Server と色が一致しやすくなります。
詳細手順:
Why am I getting Incorrect Colors when using Team Render Server
Team Render で Redshift のライティングが異なる
症状
ローカルレンダリングと比較して Team Render の結果が異なります。
例えば、
- 明るい部分が暗い
- GI が異なる
- フレームごとにライティングが変化する
といった症状です。
原因
Global Illumination はデフォルトでは各マシンごとに計算されます。
そのため、異なる CPU や GPU を持つ環境では、微妙な差異が発生することがあります。
解決方法
GI Cache を事前に作成し、すべてのクライアントで共有してください。
これにより全マシンが同じ GI データを利用するため、一貫した結果が得られます。
詳細手順:
Why does Redshift's lighting look different between my editing machine and Team Render
上記を試しても解決しない場合
ログを収集してサポートへお問い合わせください
本ガイドの手順をすべて試しても問題が解決しない場合は、ログを収集してサポートへご連絡ください。
必要なログ
以下の両方からログを取得してください。
- Team Render Server
- 問題が発生している Team Render Client
Maxon Support Tool の利用
Maxon Support Tool を使用すると、
- システム情報
- Preferences
- ログファイル
をまとめて収集できます。
ログ取得手順
- 各マシンで Maxon Support Tool を起動します。
- ログ収集中に問題を再現します。
- デスクトップに作成される
Maxon Support Log Filesフォルダを ZIP 圧縮します。
- サポートチケットへ添付してください。
Maxon Support Tool のダウンロードおよび使用方法については、以下をご参照ください。
「Maxon Support Tool Download Page」
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- Multiple clients installed, but the server only sees one
Team Render Server に関する問題が引き続き発生する場合は、サポートチケットをご送信ください。サポートチームにて調査を行います。
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